pgp.net.nz
Incident Report for InternetNZ
Resolved
This incident has been resolved.
Posted 12 months ago. Jun 15, 2018 - 15:30 NZST
Investigating
We are investigating an issue with the SKS software, the service is currently unavailable
Posted 12 months ago. Jun 15, 2018 - 14:04 NZST
This incident affected: .nz OpenPGP Keyserver.